[Ran] Nanostation M5 comme routeur local et relais pour une autre AP

Frédéric Dumusois fdumusois at gmail.com
Dim 26 Jan 22:58:05 CET 2014


Le 26 janvier 2014 22:33, Le Net du Kermeur <le.net.du.kermeur at free.fr> a
écrit :

>  Le 26/01/14 19:27, Frédéric Dumusois a écrit :
>
>     Bonjour aux membres de la liste
>
>  Je viens de connecter un nouveau membre de notre association
> Chaul'Hertz, et pour connecter celui-ci j'utilise une nanostation M5, dont
> le premier port lan0 alimente l'antenne et le second port lan 1 alimente
> une seconde antenne loco M5 qui sert d'AP pour un relais vers ce nouveau
> membre.
>
> La Nanostation M5 sert aussi de routeur (onglet network) pour le réseau
> local du membre qui héberge le relais, en l'occurence chez moi.
>
>  En conservant la configuration basique, sur Wan0 est située l'IP
> routable avec NAT, sur bridge0 (lan0-lan1) sont configurés les IPs non
> routables et le serveur DHCP.
>
> Je cherche à relayer notre accès internet sur lan1, et comme cela ça ne
> fonctionne pas. La loco M5 qui fait AP semble seulement bridgée au lan0 et
> est donc surement derrière le NAT.
>  Je la vois, je l'accède par un alias que j'ai eu la bonne idée de lui
> affecter, mais je n'accède pas la STA du nouveau connecté, même par l'alias
> dans le même sous-réseau. La liaison wifi elle est parfaite.
>
>  J'atteins là la limite de mes connaissances sur ces antennes, et sur la
> configuration de réseau en général.
>
>  J'ai le sentiment de pouvoir faire quelque chose avec les VLANs. Je pense
> par exemple:
> - mettre wlan0 et lan0 sur le VLAN 10
>  - mettre wlan0 et lan1 sur le VLAN 20
>  - supprimer le bridge existant par défaut qui lie LAN0 et LAN1
>  - supprimer la config lan qui porte sur ce bridge
>  - bridger wlan0.10 et lan1.10
> - bridger wlan0.20 et lan1.20
>  - créer l'interface lan pour le réseau local avec le service dhcp sur le
> nouveau bridge br0 liant le VLAN id10
>
>  Je vais essayer un truc comme ça mais je ne suis pas sur que ça marche.
>
>  En question subsidiaire, faut-il que les trames arrivent déjà taguées id
> 10 et id 20 sur les interfaces pour que cela fonctionne ?
>
> En attendant je vous demande conseil.
>  Si certains d'entre vous ont déjà réalisé ce genre de montage et de
> relais, je suis très preneur de leurs conseils et de leurs recettes.
>
> Voir là : http://blog.lekermeur.net/?p=1988, pour Airos >= 5.5
> ou là : http://blog.lekermeur.net/?p=1418 pour Airos < 5.5
>
> A+
> Marc
>
>
Marc :-)

Tu es un génie !

Nickel
Ca marche parfaitement, c'est tout simple. Pas besoin de vlan, rien...
Un peu déroutant pour arriver à pouvoir mettre wlan0 dans le nouveau bridge
avec l'interface web airos, faut libérer les fonctions au préalable.
J'avais bien cherché de ce coté, mais bon...

Merci merci merci

Plein de bonnes choses à vous messieurs ;-)

Et une bonne nuit

Cordialement

Fred
-------------- section suivante --------------
Une pièce jointe HTML a été nettoyée...
URL: <http://lists.vaour.net/pipermail/ran/attachments/20140126/9bbb5774/attachment.html>


More information about the Ran mailing list