[Ran] Le document ne contient aucune donnée

Didier Lebrun dl at vaour.net
Dim 14 Jan 00:04:07 CET 2007


Attila a écrit :
> D'après mes tests, le problème vient de la ligne ADSL / FT. Si je branche un 
> PC directement derrière le modem le phénomène est toujours là. Et le modem 
> n'est pas en cause car il fonctionne très bien sur une autre ligne. Pour FT 
> et Orange contacté par téléphone, tout est OK. Quelqu'un a-t-il déjà eu des 
> problèmes de téléchargement incomplets ? Cela se voit bien sur Google : on 
> lance n'importe quelle recherche, puis on affiche les pages, 9 fois sur 10 
> c'est bon et de temps en temps la page ne se termine pas (message 
> "chargement en cours"), voir ne s'affiche pas du tout. C'est également très 
> visible avec RealVNC : l'écran de l'ordinateur distant ne s'affiche jamais 
> complètement, et les commandes clavier semblent ne pas arriver non plus.
> 
Ca ressemble à un problème de fragments qui se perdent. Ce genre de 
chose peut nptamment être causé par un MTU > 1492 ou une carence de 
l'implémentation du MSS au niveau du NAT (iptables -I FORWARD -o eth1 -p 
tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu).

@+

> ----- Original Message ----- 
> From: "Attila" <attila at attilog.net>
> To: <sylvain at viviershautdebit.net>; "Reseaux ruraux" <ran at lists.vaour.net>
> Sent: Thursday, December 28, 2006 5:56 PM
> Subject: Re: [Ran] Le document ne contient aucune donnée
> 
> 
> Non, c'est pas ça. Pour tester j'ai simplifié au maximum, il n'y a plus que
> 2 WRTs, mon PC et le modem. Le phénomène est bien visible sur google :
> environ 1 page sur 5 ne s'affiche qu'à moitié voir pas du tout, en cliquant
> sur Refresh ça fini par passer. Autre phénomène bizarre : par précaution
> j'ai changé mon antenne pour une plus puissante (21 dB), j'ai maintenant un
> RSSI impressionnant (60 dB) pour un bruit "normal" (92 dB). Avec ça
> logiquement ça devrait foncer ... eh bien non ! Si je bloque à 12 Mbps cela
> n'accroche pas. Le plus que j'arrive à faire est 9 Mbps. J'ai essayé toutes
> les fréquences : pareil. J'ai modifié les Fragmentation Threshold (2346 au
> lieu de 1023) et le RTS Threshold (2347 au lieu de 1024) : c'est légèrement
> mieux, mais le problème est toujours là.
> Il doit y avoir une perte de paquets TCP, mais je n'arrive pas à le
> quantifier. J'ai envoyé une série de 1000 pings ils sont tous passés ! J'ai
> lancé des tests trouvés sur DSLReports http://www.dslreports.com/tools tout
> est bon ...
> Quelqu'un connait-il un moyen de mesurer le nombre de retransmissions et
> d'abandons dans un transfert TCP ? Les variables que l'on peut modifier ?
> Merci.
> 
> François Leleu
> www.attilog.net
> 
> ----- Original Message ----- 
> From: "Sylvain LORIOT" <sylvain at viviershautdebit.net>
> To: "Reseaux ruraux" <ran at lists.vaour.net>
> Sent: Thursday, December 28, 2006 1:10 PM
> Subject: Re: [Ran] Le document ne contient aucune donnée
> 
> 
> Coucou,
> 
> avec du retard par rapport à l'envoi réel du mail, mais bien en avance
> par rapport à la date indiquée.... Encore un noeud dans le continum
> espace-temps.
> 
> N'ya-t-il pas un conflit d'adresse IP par rapport à ton réseau en
> général. J'ai constaté un montage de route par alternance en cas de
> conflit IP, ce qui pourrait expliquer le problème ....
> 
> A pluch'.
> 
> Sylvain
> 
> Le mardi 02 janvier 2007 à 20:16 +0100, Attila a écrit :
>> Salut à tous,
>>
>> Sur l'un des PC de mon réseau maillé, derrière un routeur simlilaire
>> aux autres et seulement derrière celui-ci, j'ai un phénomènre bizarre
>> et presque systématique : une recherche sur google ne s'affiche pas
>> complètement (début de la page seulement). Parfois j'ai un message
>> d'erreur "Le document ne contient aucune donnée.", et la processeur
>> mouline à fond pendant ce termps (occupation 100% d'après le moniteur
>> systeme). Si je change de PC (et même la version de windows) cela ne
>> fait rien. Si je change le routeur non plus (cependant il est
>> paramétré de la même façon).
>> Quelqu'un a-t-il une idée ? Merci.
>>
>> François Leleu
>> www.attilog.net
>>
>> _______________________________________________
>> Ran mailing list
>> Ran at lists.vaour.net
>> http://lists.vaour.net/mailman/listinfo/ran


-- 
Didier Lebrun
Le bourg - 81140 - Vaour (France)
tél: 05.63.53.73.41 (après-midi et soirée, même très tard ;-)
mailto:dl at vaour.net
http://didier.vaour.net/




More information about the Ran mailing list