[Ran] Chacun sa route...

Dominique Guardiola Falco dguardiola at quinode.net
Mer 8 Fév 11:24:58 CET 2006


Dans mon réseau, pas encore opérationnel, les paquets se perdent :
- le DHCP ne fonctionne pas loin (un ou deux sauts)
- les connections TCP genre telnet ne passent plus après 6 ou 7 "sauts"
- meme les PING se perdent

ça tient au fait que j'ai raccordé tous mes WRT en bridge les uns  
derrière les autres,
tantot par cable, tantot par wifi.
ça donne des trucs genre :

A ---- B ---C -----D ----- E-----F -----G -----H

A peut "pinger" jusqu'à F, mais pas plus loin
H peut pinger jusqu'à C
A peut pinger H si il a son adresse MAC en cache ARP...

en gros, je vois deux types de solutions :
- mettre en cache ARP permanent toutes les adresses MAC? galère...
- "réparer" la couche TCP en utilisant les routes statiques
et là j'y connais rien... OpenWRT accepte des routes en NVRAM comme  
cela :

SUBNET_ADDRESS:SUBNET_MASK:GATEWAY:METRIC:INTERFACE

est-ce que quelqu'un verrait comment, avec cette variable, indiquer
à chaque WRT que pour toutes ses connections, il doit d'abord en référer
au WRT juste avant lui pour se rapprocher du routeur ?
Et ce WRT précedent, lui-meme je lui colle une route par défaut pour se
référer a celui d'avant etc jusqu'au routeur ?

j'ai juste compris qu'il fallait que je definisse la route "default"  
mais
la syntaxe heeuuu j'ai du mal ...


(Pour le 5Ghz j'ai pas encore de matériel pour les tests)
-------------- section suivante --------------
Une pièce jointe HTML a été nettoyée...
URL: <http://lists.vaour.net/pipermail/ran/attachments/20060208/afe987b9/attachment-0001.html>


More information about the Ran mailing list