[Ran] WRTs en cascade

Didier Lebrun dl at vaour.net
Mer 9 Nov 14:08:20 CET 2005


At 21:38 08/11/2005 +0100, you wrote:
>Encore du technique (pfff...) Il faut que je vous explique mon réseau d'abord
>Bon je vous ai ça en ascii, on ne rigole pas, il faut voir ça avec une 
>police a espacement constant (courier)
>
>      A                B           C         D           E        F
>+---------+        +------+    +------+   +-----+    +------+
>| Routeur |        | WRT  |    | WRT  |   | WRT |    | WRT  |
>| ADSL    |_(Hub)__|AP(10)|<-->|Bridge|___|AP(1)|<-->|Bridge|___(Moi)
>+---------+   |    +------+    +------+   +-----+    +------+
>               |                    (Relais 1)           (Relais 2)
>        (réseau LAN)
>
>
>
>Lien ____ : cable ethernet
>Lien <--> : wi-fi
>
>A) est le routeur ADSL, serveur DHCP / NAT
>B) est sur le toit, configuré en AP (voir config AP, plus bas)
>C) est sur un autre toit, à 750m de là, configuré en bridge (voir ci-dessous)
>   entre B et C, deux SD-15 et un débit de 5 à 6 Mbits
>D) est à coté de C, relié par un cable ethernet (LAN - LAN)
>   il a une SD-27 qui vise E à 4,5 km sur une ligne de vue dégagée
>E) a aussi une SD-27
>F) je me connecte à E sur le port LAN en ethernet sur mon portable
>
>Tous le monde est sur le meme subnet 192.168.1.x
>Les WRT sont configurés pour faire en sorte que c'est l'IP LAN qui est
>accessible, donc à partir de A, B, C, D ou E je peux "pinger" tous les 
>autres,
>et entrer en telnet dans tous les WRT.
>Les ports WAN ne sont pas utilisés.
>
>Sur le réseau local j'ai une machine qui tourne avec iperf en serveur
>pour pouvoir tester le débit de chaque point du réseau.
>
>  2 problèmes :
>
>- le DHCP : si je me plug partout, jusqu'à C, j'obtiens une IP via DHCP.
>Quand j'essaye sur E, plus de DHCP...
>Est-ce à cause de la fameuse limite des "trois switches", genre le message 
>broadcast dhcp ne franchit pas tous les WRT (qui seraient considérés comme 
>des switches?)
>et de manière plus générale, est-ce que en continuant à faire des relais 
>comme je fais, je n'aurais pas de limite ?


Kézako la "limite des trois switches" !? D'après ta "config Bridge", le WRT 
qui est supposé être en bridge est en client d'AP (wl0_mode=sta), ce qui 
explique que DHCP ne fonctionne pas au delà de C. Il faudrait mettre 
"wl0_mode=wet" pour qu'il soit effectivement en bridge. Pareil pour les 
suivants.


>(à la place de F, je mets un autre AP, pour sauter vers un autre relais, 
>qui lui-meme doit renvoyer a une autre commune ou se trouve le dernier AP. 
>En gros dans mon plan actuel, le dernier abonné sera connecté derrière 9 
>WRT en comptant le sien)
>
>
>- le débit entre D et E (LE lien important) plafonne à 850 kpbs et 
>impossible d'arranger ça - je bidouille avec frameburst, gmode, plhpcr etc 
>etc, rien à faire!
>je dis "plafonne" parceque j'ai commencé sur "D" avec une SD-15, puis une 
>SD-20, et enfin une SD-27 et toujours 800k !!! (avec, à chaque fois, la 
>SD-27 de "E" en face).
>Je cale ! Vous soupçonneriez quoi ?


Ca ressemble à ce qui se passait chez WifiQuercy tant qu'on avait pas 
trouvé la solution. Voir le post de Sylvain.


>Je n'ai pas encore appliqué le package wificonf de Marc sur ceux-là (pitié 
>Didier ne m'envoie pas l'ANF ;-) donc ils sont encore en txpwr 255, ce qui 
>pourrait peut-etre jouer, non ?

Non, pas tant qu'il n'y a pas de parois réflechissantes autour.




>Tous les WRT sont en OpenWRT RC3
>Voici les configs utilisées
>j'ai zappé les wl0_ habituels (channel, ssid, etc)
>
>config AP :
>lan_ifname=br0
>lan_ifnames=vlan0 eth1 eth2
>lan_ipaddr=192.168.1.3
>lan_netmask=255.255.255.0
>lan_proto=static
>wan_ifname=vlan1
>wan_ipaddr=192.168.8.3
>wan_netmask=255.255.255.0
>wan_proto=static
>wl0_mode=ap
>
>config Bridge (d'après le wiki d'openWRT RC3):
>lan_ifname=br0
>lan_ifnames=vlan0 eth1
>lan_ipaddr=192.168.1.4
>lan_netmask=255.255.255.0
>lan_proto=static
>wan_ifname=vlan1
>wan_proto=dhcp
>wl0_mode=sta
>
>
>
>
>
>Dominique Guardiola Falco
>Quinode SARL Coopérative
>
>
>
>            <http://www.quinode.net>http://www.quinode.net

--
Didier Lebrun
Le bourg - 81140 - Vaour (France)
tél: 05.63.53.73.41 (AM et soirée)
mailto:dl at vaour.net (MIME, ISO latin 1)
http://didier.quartier-rural.org/





More information about the Ran mailing list