[Ran] Débit limité...

verdonnaise verdonnaise at free.fr
Dim 11 Déc 20:01:31 CET 2005


Didier Lebrun a écrit :

>At 23:33 10/12/2005 +0100, you wrote:
>  
>
>>Didier Lebrun a écrit :
>>
>>    
>>
>>>At 08:38 10/12/2005 +0100, you wrote:
>>>
>>>
>>>      
>>>
>>>>>>...
>>>>>>
>>>>>>
>>>>>>
>>>>>>            
>>>>>>
>>>>>Si tu te connectes sous telnet ou ssh, est-ce que tu obtiens bien les
>>>>>réponses ci-dessous sur tes deux appareils ?
>>>>>
>>>>>~ # wl rate
>>>>>rate is 9 Mbps
>>>>>~ # wl shortslot_override
>>>>>shortslot_override is 0 (off)
>>>>>~ # wl txant
>>>>>txant is 1 (on)
>>>>>~ # wl antdiv
>>>>>antdiv is 1 (on)
>>>>>
>>>>>Pour txant et antdiv, ça peut éventuellement être 0 au lieu de 1, 
>>>>>          
>>>>>
>>selon les
>>    
>>
>>>>>versions de WRT.
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>          
>>>>>
>>>>J'ai remis le débit à 9 (je le laisse en auto normalement puisque quand
>>>>il est forcé, cela a pour seul effet visible de faire chuter le débit à
>>>>environ 200Kb)
>>>>
>>>>J'ai, depuis l'interface d'administration des WRT ((et non sous telnet
>>>>ou ssh mais est-ce important ?) , demandé les infos que tu indiques et
>>>>obtenus les résultats que tu indiques également.
>>>>(Je ne comprends que la première requête...)
>>>>
>>>>Donc semble-t-il, rien de ce côté là...
>>>>Bonne journée (je remet en Auto !)
>>>>
>>>>Patrice Valade
>>>>
>>>>
>>>>        
>>>>
>>>Bizarre !? Ton lien est un peu plus long que celui de WifiQuercy (6,3 km)
>>>et je ne me souviens pas d'un lien aussi long qui aurait été testé avec
>>>succès. Il est possible que les réglages qui fonctionnent à 6,3 km ne
>>>fonctionnent plus à 6,8 km, mais c'est étonnant, vu que les ACK timing sont
>>>en principe basés sur des multiples du SIFS de 10 µs, soit 3 km à la
>>>vitesse de la lumière.
>>>
>>>Ci-dessous qqs réglages complémentaires, qui n'ont pas été nécessaires
>>>jusque là, mais qui remédient à des défauts observés du pilote Broadcom en
>>>matière de ACK timing:
>>>
>>>~ # wl lrl 1
>>>~ # wl srl 2
>>>~ # wl cwmin 1
>>>~ # wl cwmax 1024
>>>~ # wl frameburst 1
>>>
>>>NB: FrameBurst est ok pour un pont entre deux appareils, mais no good dans
>>>le cas d'un AP qui a plusieurs clients.
>>>
>>>Pour le rate, auto est en principe à éviter pour des liens longue portée
>>>(fallback intempestif en cas de ACK non reçu), mais ça peut être
>>>intéressant de savoir quel rate est adopté en auto:
>>>
>>>~ # wl scan
>>>(attendre 2-3 secondes)
>>>~ # wl rate
>>>rate is ? Mbps
>>>
>>>(réitérer la manip qqs fois de suite pour voir si ça change d'une fois sur
>>>l'autre)
>>>
>>>Tu pourrais également essayer différentes valeurs pour voir ce que ça donne:
>>>
>>>~ # wl rate 2
>>>~ # wl rate 5.5
>>>~ # wl rate 6
>>>~ # wl rate 9 (déjà essayé)
>>>~ # wl rate 11
>>>~ # wl rate 12
>>>
>>>A part ça, tu pourrais aussi essayer les différents modes: WDS, AP/client,
>>>AdHoc. En théorie, le mode WDS est préférable pour réaliser un pont entre
>>>deux appareils, mais sait-on jamais ?
>>>
>>>Pour ce qui est d'utiliser l'interface de diagnostic, ou telnet ou ssh,
>>>c'est probablement pareil, mais je me méfie toujours des interfaces pour
>>>déboguer un problème, vu qu'on n'est jamais sûr qu'elles retranscrivent
>>>fidèlement la saisie. Il suffit parfois d'un LF escamoté ou d'un caractère
>>>mal retranscrit pour fausser les choses.
>>>
>>>
>>>--
>>>Didier Lebrun
>>>Le bourg - 81140 - Vaour (France)
>>>tél: 05.63.53.73.41 (AM et soirée)
>>>mailto:dl at vaour.net (MIME, ISO latin 1)
>>>http://didier.quartier-rural.org/
>>>
>>>
>>>_______________________________________________
>>>Ran mailing list
>>>Ran at lists.vaour.net
>>>http://lists.vaour.net/mailman/listinfo/ran
>>>
>>>
>>>
>>>
>>>
>>>      
>>>
>>Merci  pour toutes ces pistes !
>>
>>Je sors d'une phase d'essais un peu empiriques car je ne  connais pas
>>les effets de telle ou telle action...
>>    
>>
>
>lrl = Long Retry Limit
>srl = Short Retry Limit
>cwmin = Contention Window Minimum
>cwmax = Contention Window Maximum
>
>C'est des réglages résultant de l'observation des trames MAC, que j'avais 
>pêchés dans un forum. Ca vise à éviter le renvoi de trame lorsque le ACK 
>n'est pas revenu à temps.
>
>
>  
>
>>Voici ce que j'ai dans mes AP maintenant :
>> rate 2
>>CWmin 15
>>cwmax 1024
>>lrl 1
>>srl 15
>>    
>>
>
>cwmin 15 ! => cwmin 1
>srl 15 ! => srl 2
>... et frameburst ?
>
>
>  
>
>>Je suis maintenant à 1 Mbits/s bien établi semble-t-il.
>>
>>Le débit en auto est à 2
>>Je l'ai donc forcé à 2 manuellement
>>
>>Tous les autres essais de débit ont pour effet une chute très importante.
>>    
>>
>
>Ce n'est pas normal que le débit se limite à 2 Mbps avec un signal de -75 dB !
>Est-ce qu'il n'y aurait pas des interférences avec un appareil à 
>micro-ondes dans les parages ?
>As-tu observé les pertes de paquets avec iPerf en UDP dans les deux sens ?
>
>
>  
>
>>Une précision à laquelle j'ai pensé aujourd'hui : mes antennes sont
>>horizontale (élément rayonnant) y a-t-il  un sens préférable ?
>>    
>>
>
>Comme le dit justement Dominique, il vaut mieux mettre l'élément rayonnant 
>à la verticale. Tu devrais obtenir un signal un peu + élevé du fait qu'il y 
>aura moins d'absorption par le sol. Ca n'explique toutefois pas le problème 
>principal, puisque le signal actuel tient compte de l'absorption.
>
>
>  
>
>>Merci encore, le débit monte
>>
>>Patrice Valade
>>    
>>
>
>--
>Didier Lebrun
>Le bourg - 81140 - Vaour (France)
>tél: 05.63.53.73.41 (AM et soirée)
>mailto:dl at vaour.net (MIME, ISO latin 1)
>http://didier.quartier-rural.org/
>
>
>_______________________________________________
>Ran mailing list
>Ran at lists.vaour.net
>http://lists.vaour.net/mailman/listinfo/ran
>
>
>
>  
>
 Ce matin, j'avais encore 1Mb mais maintenant on est revenu à 700- 800...

Les valeurs qui étaient différentes de celles que tu m'indiquais 
correspondaient à des essais qui me semblaient donner de meilleurs 
résultats, mais ce soir, j'ai remis exactement les valeurs que tu 
m'indiquais et le frameburst à 1 et  cela ne change rien.

Je n'utilise pas Iperf pour les mesures mais simplement un test de bande 
passante sur le net. Je sais que ce ne doit pas être très précis mais 
dans mon cas, cela doit être suffisant. j'ai bien Iperf,  j'arrive à 
m'en servir sur une machine mais pas sur deux machines différentes du 
réseau...

Quant au micro ondes, 'mon four est toujours éteint' me suis-je pensé en 
te lisant et puis une image est apparu en grand dans ma tête : "un beau 
relais SFR sur le château d'eau vosin - 150 m -"...
Est-ce une piste ? (si oui, c'est une mauvaise nouvelle car je ne pense 
pas que SFR sera sensible à la gêne occasionnée...)

Et pour l'orientation de l'antenne, à l'occasion je la modifierai.

Bonne soirée et merci

Patrice Valade






More information about the Ran mailing list